HP Gen8 Blade Firmware Update Error – “Unable to Contact Update Server”

When updating the firmware of your HP blades servers form out of this box be prepared to first make sure that the correct NIC that the update process will use to contact the HP update servers is correctly configured.  As you can see in the first picture below, a generic “Unable to contact update server” will appear in the first stage of the firmware update process if the Intelligent Provisioning Utility cannot access the HP servers through the internet.  Luckily, this is a simple configuration that can be overlooked if you have Level 1 Engineers who are in charge of performing updates that don’t understand Blade Servers.

image
Above, you can see the error as described earlier.  This will show up as soon as you hit the firmware update tool if your NIC selection isn’t properly configured.

image

Locate the Intelligent Provisioning Preferences section.

image

Now, this will vary depending on your setup but here we were doing a fresh Blade Server in a fresh c3000 chassis with Cisco 3020’s.  Selecting ETH 3 was right for us here since this was the LOM “LAN on Motherboard” card that automatically maps to my switch in Bay 1.

image

Once the right NIC has been selected you can hop back into the Firmware Update tool and things should start moving along quickly.

-Justin Vashisht (3cVguy)

, , , ,

2 Responses to HP Gen8 Blade Firmware Update Error – “Unable to Contact Update Server”

  1. Derek Hughes November 1, 2014 at 10:00 pm #

    Thanks, worked for me.

  2. Ed April 27, 2016 at 11:59 am #

    Thanks. You have just save me from my misery

Leave a Reply

Time limit is exhausted. Please reload the CAPTCHA.

Powered by WordPress. Designed by Woo Themes